Intermitment response time in the Webmail interface
History
Resolved
October 4 10:04 AM SAST
The issue has been identified and server maintenance has been performed on the affected host
Identified
October 1 2:07 PM SAST
We are aware of intermittent response times within the Webmail interface, our engineers have identified the issue and are working on implementing a solution.