History

Completed
May 8 7:44 AM SAST

The scheduled maintenance has been completed.

Completed
May 7 9:37 PM SAST

The scheduled maintenance has been completed.

Scheduled
May 6 9:33 AM SAST
  • Maintenance window: 2 hours

  • Attending: Registry Engineers

  • Summary: During the maintenance window, availability checks, registrations, renewals and updates for .ORG domains may not be available.