Current network status and maintenance
Shared server Debian upgrades - Planned maintenance - 2623
Updates
-
Aug 26, 2026 7:23 AM SAST
Managed Shared Server upgrades will continue tomorrow between 06:00 - 07:00 SAST.
Scheduled -
Aug 26, 2026 7:22 AM SAST (47 seconds earlier)
We’ve completed upgrades on a batch of Managed Shared Servers. Maintenance will resume tomorrow and continue over the coming days until all remaining upgrades are complete.
Completed -
Aug 25, 2026 7:25 AM SAST (23 hours and 57 minutes earlier)
Managed Shared Server upgrades will continue tomorrow between 06:00 - 07:00 SAST.
Scheduled -
Aug 25, 2026 7:24 AM SAST (20 seconds earlier)
We’ve completed upgrades on a batch of Managed Shared Servers. Maintenance will resume tomorrow and continue over the coming days until all remaining upgrades are complete.
Completed -
Aug 24, 2026 7:25 AM SAST (23 hours and 59 minutes earlier)
Managed Shared Server upgrades will continue tomorrow between 06:00 - 07:00 SAST.
Scheduled -
Aug 24, 2026 7:23 AM SAST (1 minute earlier)
We’ve completed upgrades on a batch of Managed Shared Servers. Maintenance will resume tomorrow and continue over the coming days until all remaining upgrades are complete.
Completed -
Aug 11, 2026 3:39 PM SAST (1 week, 5 days, 15 hours, and 43 minutes earlier)
Scheduled from August 17, 06:00 AM SAST until August 31, 07:00 AM SAST
Maintenance window: 1 hr
Attending: xneelo Engineers
Summary: We are upgrading the operating system on all shared hosting servers to Debian 13 (Trixie) between 17 and 31 August 2026. Upgrades will be performed between 06:00 and 07:00 SAST during this period. We apologise for any inconvenience caused and appreciate your patience.
Symptoms: Websites and email on the affected servers will be inaccessible for a period of 10-15 minutes during the maintenance window.
Scheduled