Current network status and maintenance

Current network status and maintenance

Back
Jul 27, 2026 1:51 PM SAST

Managed server patching - Planned maintenance - 2528

Updates

  • Jul 28, 2026 10:16 PM SAST

    The scheduled maintenance has been completed.

    Completed
  • Jul 27, 2026 1:51 PM SAST (1 day, 8 hours, and 24 minutes earlier)

    Scheduled from July 28, 09:00 PM SAST until July 28, 11:59 PM SAST

    • Maintenance window: 3hr

    • Attending: xneelo Engineers

    • Summary: Managed server patching

    • Symptoms: Websites and email hosted on the affected server will be inaccessible during the maintenance window.

    Scheduled
  • Jul 23, 2026 8:17 AM SAST (4 days, 5 hours, and 33 minutes earlier)

    The scheduled maintenance has been completed.

    Completed
  • Jul 21, 2026 10:01 AM SAST (1 day, 22 hours, and 16 minutes earlier)

    Scheduled from July 21, 09:00 PM SAST until July 21, 11:59 PM SAST

    • Maintenance window: 3hr

    • Attending: xneelo Engineers

    • Summary: Managed server patching

    • Symptoms: Websites and email hosted on the affected server will be inaccessible during the maintenance window.

    Scheduled