Current network status and maintenance
Jul 7, 2026 7:53 AM SAST
Resolved after 2d
Multiple sections currently inaccessible in xneelo Control Panel and konsoleH.
Impacted:
konsoleH
xneelo Control Panel
Managed Hosting - Email
Orders
Restructures
Updates
-
Jul 8, 2026 12:30 PM SAST
Both xneelo Control Panel and konsoleH are accessible.
Resolved -
Jul 7, 2026 8:32 AM SAST (1 day, 3 hours, and 58 minutes earlier)
Our engineers have identified the issue and successfully applied a fix. Full functionality for all tools has now been restored.
Monitoring -
Jul 7, 2026 7:53 AM SAST (39 minutes earlier)
We are currently aware of an issue causing certain toolage to be affected in the xneelo Control Panel and konsoleH.
The issue has been escalated to our engineering team, who are actively investigating the root cause.We apologise for the inconvenience and appreciate your patience while we work to resolve this.
Investigating