Current network status and maintenance
Managed Server Debian upgrades - Planned maintenance - 2622
Updates
-
Aug 26, 2026 7:29 AM SAST
Managed Dedicated Server upgrades will continue on weekdays between 06:00 - 07:00 SAST and weekends between 06:00 - 15:00 SAST.
Scheduled -
Aug 26, 2026 7:28 AM SAST (41 seconds earlier)
We’ve completed upgrades on a batch of Managed Dedicated Servers. Maintenance will resume tomorrow and continue over the coming days until all remaining upgrades are complete.
Completed -
Aug 21, 2026 11:12 AM SAST (4 days, 20 hours, and 15 minutes earlier)
Managed Dedicated Server upgrades will continue on weekdays between 06:00 - 07:00 SAST and weekends between 06:00 - 15:00 SAST.
Scheduled -
Aug 21, 2026 11:08 AM SAST (4 minutes earlier)
We’ve completed upgrades on a batch of Managed Dedicated Servers. Maintenance will resume tomorrow and continue over the coming days until all remaining upgrades are complete.
Completed -
Aug 20, 2026 7:19 AM SAST (1 day, 3 hours, and 48 minutes earlier)
Scheduled from August 17, 06:00 AM SAST until August 31, 07:00 AM SAST
Maintenance window: 1 hr
Attending: xneelo Engineers
Summary: We are upgrading the operating system on all Managed Servers to Debian 13 (Trixie) between 17 and 31 August 2026. Upgrades will be performed between 06:00 and 07:00 SAST on weekdays and 06:00 and 15:00 SAST on weekends during this period. We apologise for any inconvenience caused and appreciate your patience.
Symptoms: Websites and email on the affected servers will be inaccessible for a period of 10-15 minutes during the maintenance window.
Scheduled -
Aug 19, 2026 7:37 AM SAST (23 hours and 41 minutes earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 7:22 AM SAST (15 minutes earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 7:18 AM SAST (3 minutes earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 7:12 AM SAST (5 minutes earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 7:05 AM SAST (7 minutes earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 7:04 AM SAST (1 minute earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 6:41 AM SAST (22 minutes earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 6:37 AM SAST (4 minutes earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 19, 2026 6:37 AM SAST (2 seconds earlier)
Managed Dedicated Servers have completed their maintenance now.
Completed -
Aug 13, 2026 8:36 AM SAST (5 days, 22 hours, and 29 seconds earlier)
Dedi Canaries have completed their maintenance now.
Completed -
Aug 13, 2026 7:01 AM SAST (1 hour and 34 minutes earlier)
Dedi Canaries have completed their maintenance now.
Completed -
Aug 11, 2026 3:35 PM SAST (1 day, 15 hours, and 26 minutes earlier)
Scheduled from August 17, 06:00 AM SAST until August 31, 07:00 AM SAST
Maintenance window: 1 hr
Attending: xneelo Engineers
Summary: We are upgrading the operating system on all Managed Servers to Debian 13 (Trixie) between 17 and 31 August 2026. Upgrades will be performed between 06:00 and 07:00 SAST on weekdays and 06:00 and 15:00 SAST on weekends during this period. We apologise for any inconvenience caused and appreciate your patience.
Symptoms: Websites and email on the affected servers will be inaccessible for a period of 10-15 minutes during the maintenance window.
Scheduled