Current network status and maintenance

Current network status and maintenance

Back
Jul 15, 2026 11:06 AM SAST Resolved after 2d

Connectivity issues reported for Cloudbric websites

Impacted:
Cloudbric
Web Hosting

Updates

  • Jul 17, 2026 12:28 PM SAST

    We are pleased to report that connectivity to the affected Cloudbric server has been restored, and all affected websites are now loading normally.

    Our engineering team, in coordination with Cloudbric, successfully mitigated the disruptive traffic.

    Resolved
  • Jul 16, 2026 2:10 PM SAST (22 hours and 18 minutes earlier)

    With Cloudbric, our engineering team has implemented measures to mitigate traffic to our Cloudric servers. All affected websites are loading normally again.

    We are actively monitoring the system to ensure ongoing stability.

    Monitoring
  • Jul 16, 2026 9:15 AM SAST (4 hours and 55 minutes earlier)

    Please be advised that the issue affecting websites routed through Cloudbric has reoccurred. Consequently, site availability is currently intermittent. Our technical team has been re-engaged and is working closely with Cloudbric to restore stable access.

    We apologise for this continued disruption and are monitoring the situation closely.

    Investigating
  • Jul 15, 2026 1:51 PM SAST (19 hours and 23 minutes earlier)

    Our engineers together with Cloudbric were able to find a solution and all websites using Cloudbric seems to be loading again. We are monitoring for stability.

    Monitoring
  • Jul 15, 2026 11:06 AM SAST (2 hours and 45 minutes earlier)

    We are currently experiencing access issues affecting select websites using Cloudbric. Our engineers are investigating and working to resolve this .

    Investigating