History

Completed
September 27 3:20 AM SAST

The scheduled maintenance has been completed.

Completed
September 23 8:18 AM SAST
  • Maintenance window: 2 hours

  • Attending: Registry Engineers

  • Summary: During the maintenance window, availability checks, registrations, renewals and updates for .de domains may not be available.