History

Resolved
September 4 1:15 PM SAST

The issue was identified and fixed, restore services are available again

Investigating
September 4 12:52 PM SAST

We are currently investigating the issue. Users will see "Unexpected error" when trying to run a restore