Current network status and maintenance

Current network status and maintenance

Back
Jun 8, 2026 10:59 AM SAST Resolved after 9d

High load Due to Increased Automated Bot Traffic

Impacted:
Managed Servers

Updates

  • Jun 18, 2026 8:26 AM SAST

    High load Due to Increased Automated Bot Traffic

    Resolved
  • Jun 10, 2026 2:08 PM SAST (1 week, 18 hours, and 18 minutes earlier)

    The volume of automated bot traffic impacting our Managed Hosting products has decreased and the situation has been mitigated. Some customers may still experience intermittent website performance or loading issues as we continue to monitor. Our team remains actively engaged and will provide further updates as needed.

    Monitoring
  • Jun 9, 2026 5:22 PM SAST (20 hours and 46 minutes earlier)

    The volume of automated bot traffic impacting our Managed Hosting products has decreased, resulting in improved service stability. However, the issue remains ongoing, and some customers may still experience intermittent website performance or loading issues. Our team continues to actively mitigate and manage increased crawler and bot activity.

    Monitoring
  • Jun 9, 2026 8:48 AM SAST (8 hours and 34 minutes earlier)

    We continue to monitor elevated levels of automated bot traffic across our managed fleet. While the situation remains ongoing with no significant changes since our last update, our mitigation measures remain in place and our team continues to actively manage the impact. Some customers may still experience intermittent website performance and loading issues. We will provide further updates as the situation evolves.

    Investigating
  • Jun 8, 2026 4:55 PM SAST (15 hours and 52 minutes earlier)

    We are continuing to monitor elevated levels of automated bot traffic across our Managed Hosting products. Although traffic levels have reduced significantly and overall performance has improved, some customers may still experience intermittent website performance and loading issues. Our team remains actively engaged in mitigating the impact and restoring normal service levels.

    Investigating
  • Jun 8, 2026 10:59 AM SAST (5 hours and 55 minutes earlier)

    We are currently experiencing elevated levels of automated bot traffic across our managed fleet. This may result in intermittent website performance and loading issues for some customers. Our team is actively working to mitigate malicious traffic and manage the increased volume of legitimate crawler and bot activity.

    Investigating