Current network status and maintenance

Current network status and maintenance

Back
Aug 13, 2026 3:20 PM SAST Resolved after 6h 58m

Hosting package upgrades and new hosting orders are currently unavailable

Impacted:
Orders
Internal Account Transfers
Restructures

Updates

  • Aug 13, 2026 10:18 PM SAST

    Our engineers have identified the root cause of the issue and have released a patch.

    All upgrades and new hosting orders are operating as expected.

    Resolved
  • Aug 13, 2026 5:22 PM SAST (4 hours and 56 minutes earlier)

    The root cause of the issue has returned.

    Hosting package upgrades and new hosting orders are currently unavailable.

    Our engineers are actively investigating to get to the root cause of the issue.

    Investigating
  • Aug 13, 2026 4:45 PM SAST (37 minutes earlier)

    Our engineers have confirmed that all upgrades and new hosting orders are operating as expected.

    Resolved
  • Aug 13, 2026 3:51 PM SAST (54 minutes earlier)

    Our engineers have confirmed that all upgrades and new hosting orders are operating as expected. We are actively monitoring the stability.

    We appreciate your patience and understanding.

    Monitoring
  • Aug 13, 2026 3:20 PM SAST (31 minutes earlier)

    We are aware of an issue where any hosting package upgrades and new hosting orders are currently unavailable.

    Our engineers are actively investigating.

    We appreciate your patience and apologise for any inconvenience this may cause.

    Investigating