Current network status and maintenance

Current network status and maintenance

Back
Jun 23, 2026 11:38 AM SAST Resolved after 6h 39m

Xneelo Control Panel Access Intermittent

Impacted:
xneelo Control Panel

Updates

  • Jun 23, 2026 6:17 PM SAST

    Services have returned to normal.

    Resolved
  • Jun 23, 2026 3:28 PM SAST (2 hours and 49 minutes earlier)

    We can confirm that services have stabilised ,and we are monitoring the situation closely.

    Monitoring
  • Jun 23, 2026 11:38 AM SAST (3 hours and 50 minutes earlier)

    We are experiencing intermittent timeouts when accessing products within the xneelo Control Panel. Our developers are actively investigating to resolve this as a priority.

    In the meantime, you can still access your web hosting services via konsoleH

    We apologise for the inconvenience.

    Investigating