Current network status and maintenance
Intermittent email connectivity on Shared Servers in Johannesburg
Updates
-
Sep 2, 2026 3:47 PM SAST
Our engineers are continuing their efforts to restore services on the affected servers. For now, connection remains intermittent across both webmail and email applications.
Investigating -
Sep 2, 2026 11:46 AM SAST (4 hours and 49 seconds earlier)
Our engineers are actively working to restore email services on the affected servers.
We apologise for the disruption and appreciate your continued patience.
Investigating -
Sep 1, 2026 4:23 PM SAST (19 hours and 23 minutes earlier)
Our engineers are still working to identify the cause of the email delays and connectivity issues experienced on the affected servers.
We appreciate your patience and understanding while we work to restore services to normal.
Investigating -
Sep 1, 2026 8:47 AM SAST (7 hours and 35 minutes earlier)
We are currently investigating email sending delays and connectivity issues affecting some of our servers. Our team is actively working to resolve the issue, and we will share updates as soon as more information becomes available. We appreciate your patience.
Identified